Saxum 2003

All of our components Joomla!3 compatible

We published new version of Saxum Numerology component that is compatible with Joomla!3. All Saxum components is available for the latest Joomla version.

New version of the component can be download here:

At the same time the availability and support of Joomla!1.5 version of our components are discontinued.

Donation

If you find our extensions useful, please support the development and make a donation. Thank you.



unregistered template Template by Ahadesign Visit the Ahadesign-Forum and Joomla 1.6 Live Preview